Back to overview
Downtime
Range Mate is unavailable
Nov 18 at 12:04pm GMT
Affected services
setup.range-mate.co.uk
Resolved
Nov 18 at 02:40pm GMT
Thanks for your patience, looks like all services have now recovered
Affected services
Updated
Nov 18 at 02:34pm GMT
Looks like Cloudflare is slowly coming back online, seeing more traffic getting through again. Still might see some issues with access for certain users until it's fully online.
Affected services
Created
Nov 18 at 12:04pm GMT
Due to the wider problems affecting Cloudflare, Range Mate is currently unavailable to all users. We are monitoring the situation and hope to be back online ASAP.
Affected services